Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
I want to go faster.
User avatar
By Daigle18x
#146808
Hello everyone,

Few weeks ago i've started tweaking my daughter Kawasaki KFX Barbie.

Until now, i've added the following:

A second battery in series
Push to reset 30 Amp breaker
Break control unit (to make you break more slowy)
Nailed Tire

My problem is that in (Turbo) High speed, only the right wheel spin and the power on the left one shut down.


I'm thinking that the circuit board could have stopped working properly. I don't think its the high speed button wire since one does spin. The 6 PIN switched has been check and its clean

Anybody encountered that problem before?

Thank you,

Maxime
User avatar
By Daigle18x
#146815
For the voltage, i've added a 6v to the 12v
as per the brake resistor, i've followed the instruction and put it from the orange pedal wire to the negative of the battery. But the turbo stopped working way after those modification...
User avatar
By Daigle18x
#146819
Since it's 12V will it give me the same problem if i replace it?

It's possible i did the mistake of switch side on the wire without looking that it was clearly write on the plastic what goes where...which is why it might have broke.

And is there a place that sell and ship it to canada without 20$ fee? (more than the piece itself)

Thank you,

Maxime
Lightning McQueen wiring help

Yea I did take off the switches to clean them. I g[…]

Razor Jr lil crazy

I am wanting to buy my 3 year old a razor. I have […]

Offering 20% off ALL items in the web store 11/21 […]

The LED lights I got are only good to 9W. If I wir[…]

HobbyMasters Udemy Course