Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
Need new batteries? Going from 12V to 18V or 6V to 12V? Wiring Questions?
User avatar
By Phil813
#146185
I recently bought the stage IV motor/gear package from ML Toys. I ran the new motors on 12v for a few weeks with no issues. I decided to give my son a boost and wire in the two 12V to see how it would preform. The F150 ran great for about 3-5 minutes and then started blowing 40amp fuses. I inspected both the shifter and foot pedal switches and all three have continuity and appear to be in good condition. I looked at the wiring and don't see anything pinched or unsecured. I decided to prop the rear on a bucket and test the motors in reverse and first gear and the motors ran fine. As soon as I shift to high gear it blows fuses. I am at a loss and would appreciate any help. Thanks!
User avatar
By pirsen
#146199
Try increasing the fuse rating to 50A. Check the temperature reached by the motors quickly if the fuse blows again.
Make sure that gearboxes and wheels rotate without resistance. At first I can not think of anything else, but I'm not an expert either.
The gearboxes are worth a pastry, I understand how it should feel.
User avatar
By wired
#146262
Good find. Bent axles are often overlooked. Glad you found the problem and thank you for posting the fix.

I know what your saying that would be great if you[…]

Hello all, This is my first post. I've had troubl[…]

I have little experience using the voltage meter. […]

If you charge your battery at 6A (assume this is j[…]

HobbyMasters Udemy Course