Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
This is where you introduce yourself! Share your insight, areas of expertise, or just interests.
User avatar
By hendricksen11
#145668
Greetings,
Co-worker gave us a PW Escalade. He didn't know what was wrong, but I bought a new battery and it runs fine.
Now that my kids have mastered driving it looking at maybe going to 18v and if needed upgrade motors.
Also the radio doesn't work so if anyone knows a quick fix that would be awesome too!
User avatar
By boblobllaw
#145676
I need help figuring out a problem with my wiring on a razor e300. I ordered a 36v motor/speed controler/variable spped throttle/and 3x12v batteries off of ebay. Everything wouldve been plug and play but i accidently ordered the "2 wire" setup and i had a "3 wire" setup in my scooter. I thought, "No problem. I can figure this out." I got everything put in and working. The scooter runs just fine but when i went to plug in the charger it sparked. I quickly unplugged it and everything still seems to be ok. What i need to know is why it arked so i can charge the batteries without blowing my scooter up or burning my house down. There isnt much to this stuff so i cant understand whats going on.
By Rob222
#145679
Bob, Do you have a 36v charger or did you plug in the original 24v charger ?

(oops, sorry hendricksen11, I didn't notice this was your post first)
16AH, 4s lipo 2.5 lbs $99

If you go the LiPo route, make sure you use one of[…]

It won't be trivial if you're not sure, but if you[…]

NATV is Not an ATV

I got the Power Wheels bug this year and am now up[…]

Nice -- that's some impressive speed, and it sound[…]

HobbyMasters Udemy Course