Page 1 of 1

New to PW and open to help

PostPosted:Wed May 10, 2017 8:11 am
by hendricksen11
Greetings,
Co-worker gave us a PW Escalade. He didn't know what was wrong, but I bought a new battery and it runs fine.
Now that my kids have mastered driving it looking at maybe going to 18v and if needed upgrade motors.
Also the radio doesn't work so if anyone knows a quick fix that would be awesome too!

Re: New to PW and open to help

PostPosted:Wed May 10, 2017 9:01 pm
by boblobllaw
I need help figuring out a problem with my wiring on a razor e300. I ordered a 36v motor/speed controler/variable spped throttle/and 3x12v batteries off of ebay. Everything wouldve been plug and play but i accidently ordered the "2 wire" setup and i had a "3 wire" setup in my scooter. I thought, "No problem. I can figure this out." I got everything put in and working. The scooter runs just fine but when i went to plug in the charger it sparked. I quickly unplugged it and everything still seems to be ok. What i need to know is why it arked so i can charge the batteries without blowing my scooter up or burning my house down. There isnt much to this stuff so i cant understand whats going on.

Re: New to PW and open to help

PostPosted:Thu May 11, 2017 6:32 am
by Rob222
Bob, Do you have a 36v charger or did you plug in the original 24v charger ?

(oops, sorry hendricksen11, I didn't notice this was your post first)

Re: New to PW and open to help

PostPosted:Thu May 11, 2017 10:59 am
by CJB
Total thread hijack! :lol: :lol:

Re: New to PW and open to help

PostPosted:Thu May 11, 2017 12:18 pm
by Rob222
Mea Culpa, Me Paenitet