M.L. Toys
M.L. Toys
HobbyMasters M.L. Toys
Adding R/C to your Powerwheels vehicles? Using R/C parts on your Powerwheels?
By mikeaveli007
Hi guys, first of thank you to all four all of the great information. I am almost finished with my son's f150 and the issue I ran into its regarding the LAC and it seems to have gone from bad to worse. When I first connected it up the actuator would extend and retract but would not go back to the Center\Neutral position, it would just stop when I let go of the steering control. After trying different things (switching wires around based on pictures I seen on here). The actuator would then extend all the way and I was able to retract with the control but when I released it the actuator would then extend all the way. I did some more troubleshooting testing voltages and reboots it would then not retract at all. The LAC seems to only give the actuator a +12v signal which causes it to stay extended. If I go full reverse on the control the voltage drops to 0 and never goes reverse. I even tested with a servo tester to eliminate the receiver. I'm at a loss as to how to fix it, does this mean the LAC is broken or somehow misconfigured? The datasheet for the LAC says if the actuator goes all the way to one side and stops you should switch the motor output wires but that just makes it go the other way and stop.

Here are the voltages I get

From the receiver I get .3v - .6v on the rc signal
Across the potentiometer wires I get a constant 3.33v
The input power is 12v
Outgoing motor I get 0-12v but don't get any negative voltage

Any ideas?

By Sedzy
What is the LAC board model number? Are you using an actuator with feedback for it?

I'm guessing your using it in RC mode, with a standard RC-PWM input from a receiver?

I hope one of the FETs in the H-bridge hasn't gone.
By Sedzy
Ok first... Wow. I want one. I've been looking for a linear actuator, but they're all too slow. This is awesome!! 2"/second. :)

I read the data sheet, and info on it. Going by your symptoms and issues, I'd start with the pot. It may be shot or a lose wire, making the lac think it's not where it's supposed to be.

Measure voltage from the pot ground (blue) to the wiper (yellow), then the pot + (white)to the wiper. As long as the actuator isn't all the way in or out, your voltages should be less than 3.3. (Voltage from white and blue should be 3.3 though)

Also as per the datasheet, did you try connecting it to only the rc input line (X6.3)
By mikeaveli007
Thanks for the help. I did do those measurements, and they were below 3.3v. I currently have the power and and rc input connected to the X6 connections because I didn't have a male to male server cable for the X3 input.. I should be getting one today though to test that part at least. From all the testing I have done it seems like the actuator is fine but the board isn't reading the position of the pot. I even used the Config Software for the LAC and it just shows that the position is at 100% no matter where it actually is.
By Sedzy
The 100% thing is the odd bit.

Can you for sure rule out the actuator? Set the lac aside and use a battery manually to pull the unit in. Disconnect the battery and your multimeter and measure resistance between both sides of the wiper on the pot wires. Cycle the actuator the other way and measure the resistance again.

The measurement should more/less flip. Also it'd be good to know what value of pot they use. (Resistance between white and blue)

From there we can work inward into the circuit. Is there a "set default" in the software? Then restart?
By mikeaveli007
So I did a "reset" of the LAC and then connected the servo cable without power to the X3 connection then connected power to the X6 connection. It now moves back and forth but wont go to "center" just moves and stops. The weird thing is if I powercycle sometimes it will stay extended and I will be able to retract but it then extends all the way when I release the control or sometimes it won't retract. Anyway, I did remove it and measured the resistance across blue & white and it is 10kohms like it says on the label. Measuring from blue to wiper line from both when retracted and extended there is only like a 2kohm difference. I know it should range from 0-10, so I think you were right in that its an issue with the pot... seems like the wiper wire is not working properly.
By Sedzy
This is promising progress. :)

I found the advanced config sheet for the usb software, and had a quick look through it. One thing I keep seeing, is to only connect 1 power source. So either the 5-6v from your RC Receiver or from an ext. power supply/bec. The actuator power would be a separate sub-circuit.

The range on the pot will differ on where the extension level is. I don't know how much of the pot range is used in the actuator, so it may not use the full 10K (but it should to keep a high accuracy) Are you saying you are only getting 2K between the full range of movement?

I'm wondering now if it's just a config in the usb control panel. I don't have a unit to install it on, so I can only see blurry pics. Is there something in it to calibrate and/or configure your RC inputs? This unit is used in a wide range of ways, so I have to assume it has tabs to input values in to meet your design setup. In your case, 1mS for full retraction, 1.5mS for centre, and 2mS for full extension.

if the pot values are only ranging 2K on full movement range, that sounds bad. Perhaps a call to the company tech department may shed some further light onto it. Maybe even a confirmation on a bad pot, and a new one under warranty? These aren't cheap actuators, I'd already have one in the mail if they weren't so expensive.

a final thought on the pot.... the wipers on them are far from robust... if they are not connected correctly, the wiper can easily burn out. Did you at one point or another connect the pot wires incorrectly or without the ground? (ie just the white, and yellow) That would surely burn it out once the wiper reached the top and the resistance approaches 0.
User avatar
By sall
Snap a picture of your LAC board connections. Also verify that you never had two power sources connected(receiver and battery voltage).
Last edited by sall on Wed Sep 16, 2015 1:46 pm, edited 1 time in total.
By mikeaveli007
I did try that, it was how I initially set it up because I didn't have a male to male cable. I received the new actuator and it seems to be working fine now. Only issue I seem to see with it is that it doesn't extend all the way, maybe like 80%. Other than that its working as expected.
By Sedzy
Glad it's all worked out now. :)

The 80% thing is most likely calibrating for the RC signal. The RC transmitter I have, you can set your trim for centre, as well as channel values to tweak full fwd/rev ranges.
Unibody Jeep Stock Lift

Looking for front and rear modules

Stock lift for unibody jeeps

Are the front and rear modules used for “sto[…]

The Barbie Jeep make over

Here are a couple pics of the upgraded all metal[…]

Texans in 2017?

Clicking in from Houston. I have a small fleet o[…]

HobbyMasters Udemy Course