Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
Anything that doesn't fit somewhere else & general forum updates
User avatar
By Neilvdm
#148518
My son was given a used Razor quad by friends of ours.
razor quad.jpg
razor quad.jpg (41.64 KiB) Viewed 498 times
The bike has been standing for a while as they were no longer using it. We plugged it in and charged over night.
So once you turn the throttle, you can hear a clicking sound, but the motor is not kicking in. My first thought was that the batteries went, so I replaced them, but still the same thing, only the clicking sound.

Any body that can help me as to what the problem might be? The motor?
razor quad parts.jpg
razor quad parts.jpg (46.02 KiB) Viewed 498 times
Thank you in advance


By Rob222
#148519
Hello,

Do you have a volt meter to check the batteries ? You may have a bad charger.

Also, the motor has a connector into the wiring harness. Try unplugging the motor and running the batteries (or just a single battery) directly to the motor. If the motor spins your issue is with the controller, the twist throttle, or the brake switch.

On the newer built quads you have to pull in the brake lever one time (after turning on the power switch) before the motor will run. Some kind of safety thing I think.
By Muffinman
#148543
PM me if you need a new controller. I just upgraded my Dirt Quad to 36v and have the old 24v controller and throttle sitting my garage.

How did this work out? Im in the proccess of doing[…]

Higher Amp Hour

Would there be any know issues if I were go from a[…]

Hi all I’m new here this might of been cover[…]

Quick and easy swap to 12v. Just did my nephews. N[…]

HobbyMasters Udemy Course