Page 1 of 1

Dune racer upgraded to 18v won't sustain power

Posted: Wed Mar 27, 2019 12:04 pm
by Teambleach84
Hi guys, I've taken the winter to overvolt this awesome dune racer my wife picked up for free. After much time reading threw this forum I got It wired up with the bigger 775 motors and all seemed great. The problem I'm having is the runtime is odd. My boy jumped right in and it was fast but after 5or so min it starts to really slow down until it won't run at all. Maybe 10 min total. Thinking this was odd I checked the voltage of the batteries and they were not close to being dead. Furthermore after waiting a couple minutes power would be restored and we could drive it back to the garage. So I'm guessing maybe the pedal switch gets too hot or something in that vein. I did not run new wire should I have?

Re: Dune racer upgraded to 18v won't sustain power

Posted: Wed Mar 27, 2019 3:48 pm
by M.L.Toys
Sounds like bad batteries or the wrong type of batteries. The pedal switch is on/off... it can't make the car go slow.

Re: Dune racer upgraded to 18v won't sustain power

Posted: Wed Mar 27, 2019 3:57 pm
by Teambleach84
Picked up three 6v sla batteries from interstate batteries. I have a 30A fuse between them all. I've seen people talking of rewiring everything with thicker gauge. Is that necessary?

Re: Dune racer upgraded to 18v won't sustain power

Posted: Wed Mar 27, 2019 11:18 pm
by Biggjimm
Could it be the motors are getting hot???
Just a thought.
Good luck. Jim.

Re: Dune racer upgraded to 18v won't sustain power

Posted: Thu Mar 28, 2019 5:50 am
by M.L.Toys
18v should be running a 40a fuse. If you're not popping that 30a fuse then those batteries probably aren't putting out enough power. One and done: https://www.mltoys.com/product-p/18-volt-conversion.htm