Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
If you have a question about a specific model or modification, you might find the answer here.
User avatar
By TJX
#140733
Installed new 550 motors in my sons quad... its over volted to 18v & it rips now! but is cutting out after a few minutes of riding wires getting hot then it will start again after about 30-60 sec. Is it a relay or the throttle switch killing it. Should i rewire i think its only 14ga? Never had a problem running 18v before the motor upgrade.
User avatar
By wired
#140745
If you're using a stock battery in the mix then the internal breaker is tripping and resetting. The new motors are likely pulling a few more amps.
User avatar
By TJX
#140767
Using aftermarket batteries 12v+6v... i can hear something click right before it starts working again. Would rewiring be a posible solution?
User avatar
By wired
#140773
Let's start by finding out what model quad you have. Some have an in-line breaker in the wire harness.
User avatar
By TJX
#141249
Looking for the diagram for my specific model. To see what kind of in-breaker i may have, if i need to upgrade the wires and switch the breaker?
Motors Bad?

12.2 is a dead battery! 13 is 100%

CJB Performance Electronics

I dunno, looks like its going to be easier with th[…]

Fire Rescue Jeep Major Overhaul!

Hello All! Im Back, with a new project. With your[…]

Do you think it would have been possible to keep t[…]

HobbyMasters