Gruber
HobbyMasters
M.L. Toys
KidsWheels
Gruber
HobbyMasters
M.L. Toys
KidsWheels
HobbyMasters M.L. Toys
Gruber
KidsWheels
Anything that doesn't fit somewhere else & general forum updates
#150601
I have a Camo rzr 900 Peg Perego for my toddler boys (4 and 3). It ran fine all last year and I replaced the battery because we bought it used and it was dying quickly. No big deal except I had to switch the connectors to the gray connectors. It ran fine like that for 2-3 weeks and then winter hit thinking we'd hit the ground running come spring. Got it out last week and the controls are completely backwards. Speed 2 goes in reverse quickly, speed 1 goes into reverse slower. And then reverse goes forward in first speed. I've been letting my son ride in "reverse" by keeping a weight on the reverse to keep it held down, but it goes too slow to have any fun on.

I've checked the "gas" pedal and it is 100% wired correctly. Red, white, blue, the jumper, etc. So I'm thinking it has to be in the "gear shifter". (Sorry for my terminology)

Seems like I just need to turn something around or replace a switch or something. I've search Google for days and have gotten no solid answers.

I'll even Paypal someone to diagnose this for me lol. I don't have much I will reward a solid answer that gets me closer.

(If that's not allowed I will delete, sorry)

Thanks!


So my Kids wanted faster but not much going for Be[…]

I’ve got the old school original kid trax fi[…]

I recently upgraded my kids Dora Jeep from 6v to 1[…]

"Best Choice" Jeep?

Best Choice Products (BCP) Jeep 24v Upgraded from […]

HobbyMasters Udemy Course